Mikrotik and OVH Failover IP / Hyper-V

First you need to create Virtual Switch.

  1. On the command line of the host server run IPconfig /ALL
  2. Note the name of the network adapter that contains the IP address of the server’s assigned IP.
  3. In Hyper-V manager create the a new virtual switch.
  • Connection Type is External
  • Select the adapter with the server’s IP
  • Check Allow management OS to share this network adapter

Capture1.PNG

This step only is required once for a hyper-v server. For all VMs, a virtual switch is required to connect the VM's virtual network adapters to the server's physical adapter.

 

Then select the VM that you wish to add the Failover IP. Use the Hyper-V Manager to change the settings of the VM (it needs to be shutdown).

 

  1. Expand the Network Adapter and click on Advanced Features.
  2. Change the MAC address to Static and enter the Virtual MAC address for Failover IP.
  3. Press OK to apply changes.

Capture2.PNG

 

 

Mikrotik:

/ip address add address=xxx.xxx.xxx.xxx interface=ether1 network=yyy.yyy.yyy.254

/ip route add gateway=yyy.yyy.yyy.254

 

xxx.xxx.xxx.xxx - your Failover IP

yyy.yyy.yyy.254- Gateway address dedicated server

 

Была ли эта статья полезной?
Пользователи, считающие этот материал полезным: 0 из 0

Если статья оказалась вам полезна, пожалуйста, отблагодарите посильной суммой :)

Еще есть вопросы? Отправить запрос

0 Комментарии

Войдите в службу, чтобы оставить комментарий.
На базе технологии Zendesk